NextPreviousHomeUpgrade process

MrGruntHunter | 7 years ago | 35 comments | 2,908 views


I just want to confirm the upgrade process. I downloaded your version 12 when it was first released and now I see you have had several upgrades since then. I started the upgrade process until it said it was going to completely uninstall BT on my computer so I got nervous and backed off.

My question is "in the upgrade process does the older version get completely uninstalled and then an entire new program then get installed containing the latest upgrades?

I just want to confirm this before I do something stupid ......... not that I'm prone to doing things like that but my advancing age does have a mind of its own at times ;-)

Share this on FacebookShare this on Twitter

The installer uninstalls the old version before it installs the new one.

Does this answer your question?

michiel, 7 years ago

Yes, thank you. It caught me by surprise and scared me when I said it was going to uninstall everything. I'll proceed with the upgrade now.

MrGruntHunter, 7 years ago

Oh Oh The upgrade seem ed to go ok except now none of the VJ_*.fx demo shows work where you animate text, spectrumanalyzers, speakers, vumeters, etc. etc. The sound plays but that's all.

Did something change with those shows?

MrGruntHunter, 7 years ago

Nothing has changed in the VJ effects since version I just tested the latest version on all test machines and everything works fine.

Maybe you have applied the VJ effect to the wrong layer. You have to apply it to the layer you want to make dance to the beat.

Or maybe your audio file uses an obscure format.

More info can be found on this page:

michiel, 7 years ago

It's not the shows I created. I'm trying to view the demo shows and all of the 11 shows are not working. When I boot up BT I then select Open Show I go to where they are located and I can see all the thumbnail images. I'll select one and try to play it but the images (speaker, beginning of the Bonus Spectrumanalyzer 3D circle will show up but that is all.) in just about all of them isn't there. They all worked fine before I did the upgrade.

I haven't done anything to those shows other then added an audio layer to them right after I downloaded version I noticed they weren't working after I downloaded the upgrade and then run the DEMO option under the HELP command. I even went back and downloaded the latest version of BT from your site just in case something may have gotten corrupted but it's still acting the same way. The only thing I haven't tried to do it go and try and create an entirely new show.

If it would help I maybe could do a Screen Recording of me trying to open and run the shows and send it to you if that would help.

MrGruntHunter, 7 years ago

Is it possible to go backwards to the basic version ?

MrGruntHunter, 7 years ago

When you choose HELP > ABOUT BLUFFTITLER, which version is displayed?

michiel, 7 years ago


Everything was working fine until I downloaded and installed the latest version.

MrGruntHunter, 7 years ago

That's good!

Can you now perform the following 4 steps:
1) choose FILE > NEW SHOW
2) choose MEDIA > CHANGE EFFECT... and select the VJ\VJ_Dancer effect
3) choose LAYER > ADD LAYER > ADD AUDIO LAYER... and select an audio file
4) click on the PLAY button

Are the letters jumping to the beat?

michiel, 7 years ago

Everything looks fine, I see the letters, but as soon as I select PLAY the letters disappear and I only hear the music.

Pretty much the same thing that's happening with your included DEMO shows. When I try using the speaker it all shows up until I hit PLAY then the gold speaker cone disappears, I hear the audio but nothing is animated.

MrGruntHunter, 7 years ago

This is very strange. Have you tried other audio files?

And what do you mean with "included DEMO shows"? I'm puzzled by this because no installer has ever included a VJ show. Where have you found those DEMO shows?

michiel, 7 years ago

When BT opens up there is a 'show' present. I go to HELP and select DEMO and they play. I guess they are called something else then but that's what I am talking about.

These are the 'demo' shows I'm referring to that are mentioned on your website:

"Lots of templates

The installer comes with hundreds of demo shows.
Learn more"

In a July 1st, 2014 posting you made regarding the release of Ver 11.2 you discussed the new VJ effects and said to "DOWNLOAD MEDIA FILES" which I did. That's where I obtained these 'shows' from.

MrGruntHunter, 7 years ago

Aha, that explains it!

I tried the shows and experienced no problems. Have you already tried other audio files?

michiel, 7 years ago

Yes I have and I get the same results :-(
When I open up the 'show' the image is there but as soon as I click on PLAY the image disappears and the music plays fine. I don't see how an audio file could effect an image file. Puzzling !

I reloaded the speaker 'demo' show and this time selected the audio layer and then unchecked the little visible box and played the show. No audio of course but this time the image didn't disappear or change. The audio files I am using are MP3 files and like I mentioned they all worked fine until I did the upgrade.

I have the program 'My Screen Recorder ' and could record my actions as well as anything else you might need to see if that would be any help.

OK, I made a little screen recording and posted it on YouTube:

MrGruntHunter, 7 years ago

Video looks fine, I can't see anything problematic. I tried to reproduce the issue but unfortunately it worked flawlessly on all machines I tried. I'm afraid I can only advise you to try (that's the version I used) and if that does not work go for a downgrade.

michiel, 7 years ago

Just tried to upgrade to and I get an error message:

Error opening file for writing
C:\Outerspace Software\Blufftitler\BluffTitler.exe

And I get a choice to:
Abort Retry Ignore

Retry wouldn't do anything so I had to choose Ignore
I'm still getting the same results

I'll try and go back to your article regarding version 11.2 and use your DOWNLOAD MEDIA FILES to see if that will help.

MrGruntHunter, 7 years ago

That's because you have forgotten to close the app before running the installer.

You can't replace an .exe when it's running.

The installer warns you for this. If you don't do this you end up with an old executable with new media files causing all kinds of weird behavior...

michiel, 7 years ago

OK, as you were replying I did go back and reinstall and also reinstalled the VJ files. The VJ files are located:

C:\Outerspace Software\Blufftitler\Media\Effects|VJ

But I'm still getting the same results. Something must be, or is getting, corrupted. Is there anything else I could show you that might pinpoint the problem?

MrGruntHunter, 7 years ago

All the VJ effects come with the installer so no need to install them separately. You can place effects anywhere you like, but overwriting installer files is never a good idea.

I'm out of ideas. Please let me know if the downgrade works.

michiel, 7 years ago

Happy to find this thread (thanks Michiel)!
I'm having the EXACT same problem as MrGruntHunter and got to thinking about codecs. On a whim, I changed my audio file from an MP3 to a WAV sound file, and VJ Effects now work perfectly! Apparently there is something wrong with my MP3 Codec on my system (or something else?) which allows BluffTitler to play the file with good audio output, but not recognize it and make the characters dance. Now, back to exploring the root problem... At least we are making progress!

amiga, 7 years ago

Uninstalling K-Lite Codec Pack (which I had only just installed) fixed the issue. Now Bix is happily jumping to both WAV and MP3 files. Not entirely sure the uninstall was the sole fix, as I was disabling other codecs too. Nothing seemed to work until I got to the K-Lite uninstall. MrGruntHunter, do you have that on your system?

amiga, 7 years ago

Thank you Amiga, for the missing info:

You don't have to uninstall K-Lite

I didn't have this issue but I could replicate it and fix it with the Codec Tweak Tool, so again a codec hell issue with the merit system of windows 7 and higher.

Open the Codec Tweak Tool in your K-lite folder > Win7DSFilterTweaker > Preferred Decoders > MP3 (third from below) and change to microsoft on 32 and 64 bit) > Apply and close. Restart Blufftitler.


komies, 7 years ago

I just checked and both of mine were already set to MicroSoft.
Maybe I need to do the uninstall !

MrGruntHunter, 7 years ago

then set it to another codec.

The problem is that there are more then one under your MP3 and for me it's the microsoft that worked and works again after using another. That why it is called Codec hell.

komies, 7 years ago

Eureka ! ! !
Uninstalling the K-Lite pack did the trick! VJ Demo files working perfectly now.

Now I'll need to go back and see if the reason I loaded K-Lite is still a problem (trying to load a video file in one of the templates where it wouldn't show up.

Many thanks for you guys reading my post and commenting. I was afraid Michiel was probably thinking I am some sort of nut case and a complete idiot for not knowing how to use a computer. Seeing that you guys could replicate my problem made me feel a LOT better ha haha

MrGruntHunter, 7 years ago

You are correct Komies about 'codec hell' ! Now that I uninstalled the K-Lite the videos no longer appear in my template shows. Now I have to go back and resolve that issue again. I feel I'm getting into an endless loop here !

MrGruntHunter, 7 years ago

Aha, so it's an audio codec issue.

Thanks to amiga and komies for solving the mystery!

It's a pity it wasn't a BluffTitler bug because that would have been much easier to fix. Changing the Windows codec architecture is a bit out of our hands...

When you remove your video codecs, your videos won't play anymore so that's not the solution. I think komies is right and the K-lite Codec Tweak Tool is the answer. Good luck tweaking!

michiel, 7 years ago

When you used your K-Lite Tweaker Tool how many options did you have for MP3 ? I only have two; Microsoft or LAV and I've tried using both with no success. Right now if I want to see the VJ Effects I need to uninstall the K-Lite pack or if I want to use the Video Layers I need to install it. There surly must be a better fix.

MrGruntHunter, 7 years ago

I had the same problem, which is why I had only just installed K-Lite Codecs in the last week or so. Unfortunately installing it didn't help BT show video layers. BUT, when I uninstalled it (along with disabling nearly EVERY codec I had installed, now EVERYTHING works. VJ Effects, video layers, etc... I don't know if it will help, but I ran a "Portable App" called "InstalledCodec", and used it to disable everything but a few. Those were mainly the ones that I wasn't able to disable. At this time (using InstalledCodec, these are the only active codecs I have. All others are disabled, and as I said, everything works fine (for now):
Microsoft DTV-DVD Video Decoder
Microsoft MPEG-2 Video Encoder
Microsoft MPEG-2 Encoder
RDP DShow Redirection Filter
Microsoft MPEG-2 Audio Encoder
Microsoft DTV-DVD Audio Decoder

Good luck with that!

amiga, 7 years ago

Does the K-Lite Tweaking Tool do the same thing? I'll do a search in the mean time to see if I can find " InstalledCodec".

This is insane that there isn't some sort of standardization with this stuff. I had never heard about Codec issues before until this came up when I was trying to create a video layer in BT.

MrGruntHunter, 7 years ago

Dear mister Grunthunter,

Did you close and restart blufftitler after you made and saved the changes in Codec Tweak Tool? If not do so. and or a pc restart?

You have installed the Basic version of K-Lite right?
Open Codec Tweak tools > General > Fixes > Click the select all > Apply and close.

If you have broken codecs it will ask you to remove than > click yes.

Restart Pc, and try it again first blufftitler and see if it now both works.
If Not Set the MP3 to another Codec.

Fingers crossed X

komies, 7 years ago

KOMIES ...... I think your 'Crossed Fingers' worked :-)
I uninstalled all the K-Lite and then reinstalled the basic (I also unchecked the associate files box) and then accepted it to tun the TWEAK TOOL, then selected General, Fixes, Select All, applied and close then did a complete restart of my PC.

I opened up BT and run my template show with the video layer and it played fine. I then Opened up one of the DEMO VJ Effect shows (the one with the speaker) and it played fine also.

Now if I can figure out how to work my keyboard and mouse with my fingers crossed I might be OK :-)

Thanks You AGAIN so much

I'm going to open BT back up and select the HELP > DEMO and let it run for awhile and see what happens. The only little quirk I've experienced with BT running in the DEMO mode is that usually the VJ Demo shows aren't animated at first but as soon as I stop it and then press play again they run fine. Might be something to do with the way they are running in the DEMO mode, but all appears to be OK anyway.

MrGruntHunter, 7 years ago

Not sure if it will help, but the InstalledCodec program is available from the Portable Freeware Collection at

Other great portable apps can be found at

(I'm not affiliated with either site, just a big fan of freeware, especially when you don't have to "install" it)

By the way, Michiel, BluffTitler is also "portable", is it not?

amiga, 7 years ago

are you right or left handed?

Use your hand that has no fingers crossed for the mouse and alternate this uncrossed hand with the keyboard. (you can also use your ringfinger and pinky to click the mouse buttons).

use the onscreen keyboard so you can use the uncrossed hand to typ on screen:

Open On-Screen Keyboard by clicking the "Start" button , clicking "All Programs", clicking "Accessories", clicking "Ease of Access", and then clicking "On-Screen Keyboard"

or use the voice recognition to control Windows and Apps:

Open Speech Recognition by clicking the Start button Picture of the Start button, clicking All Programs, clicking Accessories, clicking Ease of Access, and then clicking Windows Speech Recognition.

Say "start listening" or click the Microphone button to start the listening mode.

other alternatives are: a pencil in mouth, ask relative, train your pet, buy keyboard with builtin mouse pad, use laptop or windows tablet, use Stephen Hakings wheelchair, Activate Remote Desktop and invite someone you can call and they can typ and use mousepointer on your pc.

If all above does not work, contact by this forum and I will find a solution :) Because this is easy, unlike Codec hell.

Good to know that it works now.

komies, 7 years ago

I downloaded 'InstalledCodec' and when I ran it I almost fell out of my chair. I had 111 line items show up of which 6 appeared to be associated with K-Lite, 1 with Google Earth, 13 with GoPro Tools and the rest with Windows and Windows\System.
I didn't see any of the 6 encoders that you have ..... but .... everything seems to be working now.

komies ...... you're killing me ha ha ha :-)

MrGruntHunter, 7 years ago

Comment to this article

You must be logged in before you can comment to this article. Login | Register

More by MrGruntHunter

About MrGruntHunter

Dell PC WINDOWS 10 PRO, 64-bit, Ver:1607, OS BLD: 14393.1066
INTEL Core: i7-4790, CPU @3.60 GHz, Instld RAM:16.0 GB
GeForce GTX 745, Driver ver: 376.53, Tot avail grap: 12225 MB, Ded vid mem: 4096 MB DDR3
Shared Sys Mem: 8159 MB, DirectX Runtime Ver:12.0

Contact MrGruntHunter by using the comment form on this page or at