NextPreviousHomeBlack Levels on Video Export Crushed



EditKey | 3 years ago | 15 comments | 1,248 views

I have noticed that the exported Black Levels in video files are modified when exporting using uncompressed or compressed codecs. These Black Levels are below blanking by approx. 5%, and change the level contours (black & gamma) of the graphics and videos imported to a BluffTitler Show. Shadows, edges and imported graphics have greater contrast and lower brightness. This effects greatly any composites used for exported alpha channel videos. Is there a setting whereby the black levels can be returned to their normal (standard) level. This reminds me of the days of analogue NTSC verses PAL black level differences, when NTSC black levels were set higher than PAL black levels, but this time in reverse. A waveform display (above) showing the differences in black levels at import before compositing, and after the export to video file. Any thoughts would be appreciated. Cheers.


Download media files (5.1 KB)

Share this on FacebookShare this on Twitter

Some ideas:

Could this be caused by lighting? Choose MEDIA > Change effect.. and apply the NotLightened effect to turn of all lighting.

The camera layer has a few props that adjust the colours: BRIGHTNESS, GAMMA and COLOUR INTENSITY. Make sure to set them all to their defaults.

Make sure the COLOUR property of your video layer is set to (255,255,255).

Make sure the transparency property of your video layer is set to 0.

Video layers are rarely rendered in the exact same resolution as the original. Maybe your graphics card does nasty things when scaling it. Take a look at your global graphics card settings: right click on the desktop.

michiel, 3 years ago


Hi Michael. Thanks for your timely reply. I have adjusted the parameters as outlined in your previous message with no success. I'm only using three layers: Layer1= Camera, Layer2 = Ambient Light, Layer3 = Picture (SMPTE Test Pattern bitmap). Using Tektronix waveform monitor & GVG Edius waveform monitor as my guide. I trust you understand the two types of digital video level boundaries: 0-255 and 16-235. My guess is that one of the boundaries are being used in the BluffTitler application and the encoders are somehow confused, and using the other boundary, hence the discrepancy in video levels. I only picked this up after importing animations from BluffTitler into Edius, where the gentle shadows behind various elements now appear quite dark. One look at the waveform monitor revealed what was going on. If you require further information, please do not hesitate to ask, as I need this resolved. Only purchased several hours ago.

EditKey, 3 years ago



Above is another example using a black & white test card created using Windows Paintbrush, with a grey scale in the centre. It can be clearly seen the extended white levels and the super black levels generated with BluffTitler. The video card within the workstation is a nVidia Quadro 4000, latest release. My laptop is also displaying this issue. Thought a cross-check may be warranted. Cheers.

EditKey, 3 years ago



Interesting issue. I don't have a tool to measure the black levels, but did the following:

I created a test picture with 4 colours: (0,0,0), (50,50,50), (123,123,123) and (255,255,255).

I rendered this picture in BluffTitler with a picture layer using the NotLightened effect.

I tested 5 outputs:
1) a screenshot of the preview window
2) exported as picture, PNG format
3) exported as picture, JPG format
4) exported as video, Uncompressed AVI format
5) exported as video, MP4 format

The 4 colours of all 5 outputs had the exact same RGB values as the original picture.

As an extra test, I imported all the 5 outputs and exported them again. This gave the very same result.

Shouldn't I get different RGB values if the black levels were crushed?

michiel, 3 years ago


Hi Michael. I am not getting the same results as you have observed. Can you email me the "Show" that you used to achieve this, and I will have a look tomorrow. Include the test graphic as well. Its late here in Australia. Very late. You have my email address from today's registration of the BluffTitler application. Cheers.

EditKey, 3 years ago

I've attached the test show to this article. Click on the DOWNLOAD MEDIA FILES button at the top to download it.

Curious to solve the mystery!

michiel, 3 years ago


@EditKey
Sounds like a 16-235 range for tv setting, instead of a 0-255 Full RGB PC setting.

First get and install the K-Lite codecs which contain the LAV Filters set in de LAV video decoder under Video Settings RGB output levels to 0-255 PC.

Now make sure that these codecs are set in BluffTitler under Settings / Options / Drivers / Decoder Filer if you export as MP4 also set the Encoder profile to High (HiP, 100) for this.

For other exports make sure that your videocard is also set to 0-255 Full Pc.

AMD Radeon:
open Amd Catalyst under My Digital Flat Panel and select Pixel Format and Choose either RGB 4:4:4 Full or YCbCr 4:4:4

NVidia:
open Nvidia Control Panel Under Display / Resolution / set Output Dynamic range to Full.

Also for the best Quality output use the Uncompressed Avi and Re-encode to MP-4 with your favorite Video converter and delete the large Avi file.

Hope this works for you.

www.outerspace-software.com...

komies, 3 years ago




Thanks Michiel & Komies for the files and the information. Have tested your SHOW Michiel with no change in the extended white levels and super blacks. Sadly the problem remains. On a positive note, at least my SHOW was the same as yours, so at least we are using the same setup. The problem only exists with video export, the picture exports are fine.

Have tested under Win10Pro and Win8.11Pro on the same workstation, different partitions.

“Sounds like a 16-235 range for tv setting, instead of a 0-255 Full RGB PC setting.” I think there is an issue somewhere in the BluffTitler application when exporting to video with an alpha channel. As I cannot find any other issues external to the application. My nVidia settings are correct as per Komies recommendation.

It would also seem that not all computers, in particular laptops, have the option to select “Output Colour Format” and/or “Output Dynamic Range” with the nVidia display software. Both my wife’s and my laptop do not have this option. One does have the nVidia Optimus GPU switching application, the other does not (Intel only display).

Are the K-Lite codecs used to render video/graphics/text within the BluffTitler application, or only required for exporting to file?

I do not export to MP4 (h.264), as this format does not have the ability to include an Alpha channel. Only uncompressed AVI with alpha and SpeedHQ SHQ7 compressed are required. SpeedHQ is a magnificent codec, as it is freely available from Newtek, and works in almost all video applications I have available. Including VLC Player (3.0.3), Windows Media Player, Adobe Suite, Grass Valley systems, and even FFMPEG can decode this video format. Your implementation of SpeedHQ as an AVI file is perfect :).

If you require an application with a video waveform monitor in the short term to evaluate this issue further, GV Edius has a free 30 day trial available with no limitations. Edius is used extensively around the world by broadcasters as well as video professionals. www-en.ediusworld.com...

EditKey, 3 years ago

Good to hear the picture export is fine!

None of the K-Lite, or other codecs are used when you export as uncompressed AVI or MP4.

I did 2 extra tests:
1) export as PNG with transparency info (32 bits)
2) export as uncompressed AVI with transparency info (32 bits)

Both exports did not show any anomalies.

Maybe the SpeedHQ codec is the problem.

michiel, 3 years ago


SpeedHQ exported as AVI with Alpha is still successful, as are Grass Valley HQ/HQX, MP4 (H.264), Uncompressed AVI with & without Alpha, DivX, Microsoft RLE and others. Exporting appearing to be successful provided the encoder is installed and registered with the system.

I think the issue stands with the GPU and the rendering within BluffTitler and how and which of the digital video level boundaries are used with nVidia hardware. A colleague has provided a laptop which only has the Intel HD Graphics, and this exports correctly. The Intel settings are: Video/Color Enhancement/Driver Settings/FULL. So I suspect there is a problem in how BluffTitler handles the various versions of nVidia GPU hardware/software available.

Have you tried the offer to download GV Edius so that you can accurately see this behaviour with a waveform monitor. Michiel can you tell me the manufacturer and model of the video display card/s you are testing with, and the operating systems. Also the build/version of the nVidia drivers used.

EditKey, 3 years ago

Which RGB values do you get when exporting my test show as uncompressed AVI?

And what are the values when using compressed AVI using the SpeedHQ codec?

As you know, they should be 0, 50, 123, 255.

michiel, 3 years ago


The RGB & IRE Percentage figures are identical for both the Uncompressed AVI and the SpeedHQ AVI. The only difference between the two codecs is minor quantization noise/artefacts due to the compression ratio for SpeedHQ.

The numbers : 0, 39,124, 255

The IRE values (as best as can be read on the waveform monitor) :

Black 000 = -5%
Grey Dark 039 = 17%
Grey Light 124 = 50%
White 255 = 110%

This may be an issue with the nVidia Quadro series display cards or the EDID commands returning to nVidia from the display monitors. I’m reading through the nVidia technical manual and the NVAPI manual for clues. I’ll also check for the latest driver update from nVidia and any issues reported by Users. All other software packages are performing correctly at this time. There are no errors/warnings reported in Event Manager or WER.

EditKey, 3 years ago



Michiel I believe the solution is as follows. My system has three display monitors, of which two function exclusively for workstation tasks and the third as a traditional television display for final program output. It would appear that the Samsung TV display EDID was secretly telling the Quadro display card to operate in the 16-235 range. This information was not updated in the nVidia Control Panel, even though the nVidia Control Panel continued to indicate FULL Dynamic Range.

Updated the nVidia drivers to version 391.89 (current) with no problems. Then went about manually forcing various settings to over-ride the Samsung display. A process of trial & reboot. Above is the outcome of my investigations, and the settings that at least work with my system. The RED blocks indicate the changes necessary. The combination of settings always look so simple after the fact. Hope this assists others in the future. Thanks for your guidance and patience. Cheers.

EditKey, 3 years ago

Komies was on the right track.

vincent, 3 years ago


Thanks for the info. Happy to hear it works now!

michiel, 3 years ago


Comment to this article

You must be logged in before you can comment to this article. Login | Register