NextPreviousHomeRéflexion (mentale) sur Open-cube 3D.


Alex-Raymond T. | 7 months ago | 12 comments | 1 like | 428 views

vincent likes this!

En complément à l’article de aki « About reading OBJ files », je me suis aperçu il y a quelques temps déjà que BluffTitler ne lit pas les faces vues de l’intérieur, alors que cela marche avec la visionneuse 3D. Voici le remède que j’ai trouvé pour éviter cet inconvénient. Cette solution, à partir de Blender, m’a permis par exemple d’avoir le visuel à travers les vitres de l’avion lors de mon dernier article.
Fichier Open-cube 3D:
drive.google.com...

In addition to aki's article "About reading OBJ files", I noticed some time ago that BluffTitler does not read the faces seen from the inside, although it works with the 3D viewer. Here is the remedy I found to avoid this inconvenience. This solution, from Blender, allowed me for example to have the visual through the windows of the plane during my last article.
Open cube 3D file:
drive.google.com...




Share this on FacebookShare this on Twitter

probablement comme je l'ai expliqué cela dépend des "normales", en appliquant l'extrusion même à zéro, les normales sont recalculées.

en fait si vous faites un recalcul des normales vous verrez la transparence inversée. Cependant bon à savoir qu'avec zéro extrusion cela se comporte comme un recalcul complet. Merci

Franco Aversa, 7 months ago


The faces in the OBJ file are one sided, but Windows 3D viewer renders them all as double sided.

To make a face double sided in BluffTitler, make a copy and flip the winding order of the vertices in the polygons (clockwise or counter clockwise).

Unfortunately Blender confuses the winding order with the normals, or thinks that those are the same. Those are 2 very different things:
-the winding order determines the visible side
-the normals are used for lighting

Here's what I do:
-Copy the object in the scene collection
-In EDIT mode, choose Mesh > Normals > Flip
-In the export as OBJ dialog, mark the KEEP VERTEX ORDER checkbox in the GEOMETRY section

There's also a BACKFACE CULLING checkbox in the material properties, but I don't know what that does.

michiel, 7 months ago




I have a similar issue. The model being an empty cube with 2 holes on opposite sides. When importing that OBJ to BluffTitler and looking through the cube through those holes, you cannot see the "walls" of the cubes from the inside so to speak.

I have tried all sorts of combinations of non-Triangulated - Triangulated - Normals aligned - Normals reversed but the result in BT is not perfect. See the image, the bottom screendump has the mesh Triangulated and Normals reversed. The behavior is strange, depending on the rotation of the cube, either one or two sides of the cube does not show up. The side that is closest to the camera never shows up.

There's no difference using BT 15.8.1.4 or 15.8.1.2.

Regards
PiPPi

PiPPi, 7 months ago

PiPPi, it's not about the normals. The normals are only used for lighting. BluffTitler computes them when they are not present in your model. So normals are not essential.

It's about the winding order: the order of the vertices in your polygons: clockwise or counter clockwise. This determines which side is visible. To speed up rendering, all faces in BluffTitler are single sided. To make a face double sided: copy it in your modelling app and flip the winding order.

michiel, 7 months ago


@Michiel
thanks Michiel I learned a new thing, I didn't know this.

Franco Aversa, 7 months ago


Thank you all for your details.
At the beginning, to get around the problem, I made double-walled boxes (case of my shows with Hollywood), then I arrived at the method that I developed above.
Thanks to Michiel for his explanations and his method, which I will try to develop.

Alex-Raymond T., 7 months ago


Michiel, my last post up here was before I saw your replies so it looks a tad confused.

Whatever. The behaviour of the imported cube changes depending on the Normals being reversed or not, no matter triangulation or not.

I know about vertex winding order from working with vector software where reversing the order of the spline solved a problem now and then.

For 3D-models I use Cinema 4D and I have now spent about two hours testing and looking all over for something along those lines but no go. As far as "copy [the face] in your modelling app and flip the winding order", that takes me nowhere. What does that mean? Copying an individual face of the model etc? There's a "Change point order" command but like I said, no go.

Does anyone have a hint on solving this issue with C4D?

Regards
PiPPi

PiPPi, 7 months ago

PiPPi, maybe "winding order" is too technical. Maybe searching for something like "Cinema 4D export OBJ faces double sided" gives more useful results.

michiel, 7 months ago




Thanks, like I explained earlier, I know what winding order is and have used that knowledge to my benefit in vector graphic software for years but I'm totally stumped on that subject when it comes to C4D.

As for exporting, I've spent another hour trying every OBJ export option and combination thereof in C4D but no matter what, it does not give me a correct representation in BluffTitler. Shaking out that testing, I get two distinct and different results in BT as per the attached image, and none of them are correct.

What makes the difference between the two results is using either "Flip faces" or "Flip UVWs", it gives me "Case 2" in the image. All else gives me "Case 1".

PiPPi, 7 months ago

That's because flipping the faces does not make them double sided. It only changes the visible side.

To make them double sided, make a copy and flip the faces of the copy. Or of the original, but not both.

You can render single faces double sided in BluffTitler by applying the Picture\DoubleSided effect and setting the FX SINGLE SIDED prop to 1. That works, but it's much better to import proper models.

michiel, 7 months ago


Thanks michiel, I finally figured it out. Back then I thought you meant copying and flipping individual polygons which was a mess but it was easier than that. As a bonus, the solution had nothing to do with the export settings.

This is how to do it Cinema 4D R20.
- In C4D, copy and paste your finished polygon model.
- Select one of the polygon models. The entire model, no need to go for polygon selection.
- Reverse the normals for that model.
- Select both models.
- Right-click and choose "Connect Objects + Delete".
- Export the resulting model as an OBJ, use the standard export settings.
- Import into BluffTitler and do your work.

That's it. The result is a working non-submodeled model in BT, see the clip.

PiPPi, 7 months ago

Happy to see it works now!

Also thanks for the instructions. You can make this even more helpful by posting it as a new article with the title "How to make faces double sided in Cinema 4D". This way other users who struggle with the same issue will be able to find you using Google!

michiel, 7 months ago


Comment to this article

You must be logged in before you can comment to this article. Login | Register

More by Alex-Raymond T.

About Alex-Raymond T.

Tutoriels et packs sur le montage vidéo avec BluffTitler et MAGIX VideodeLuxe:
youtube.com...

Contact Alex-Raymond T. by using the comment form on this page or at rterrien@live.fr