NextPreviousHomeWord-wrap on specific width

IBMedia | 7 years ago | 8 comments | 1,764 views

I initially thought that the BOUNDS property of thr text layer would help me do this, but that scales my text to fit the width, so I get different tt sizes in each paragraph - and that looks odd.

I'm wanting to create 2 or 3 paragraphs of text and have each paragraph be the same width, and use the same size characters - Much like a set of bullet points, or indented paragraphs in a word processor.


I've tried several things to achieve this look and none has worked.

Is there a simple setting that I have missed somewhere that would enable me to do this?




Share this on Facebook Share this on Twitter

So if your text layer is automatically scaled to make it fit you want another text layer to be scaled as well?

michiel, 7 years ago


No, I was hoping that I could use the Bounds property to set a width, and the text would "wrap to that width.

By having the same "X position" and same "Bounds width", I could have multiple "paragraphs that were left aligned.

I know I could manually change this in each show and achieve what I want, but I'm creating a "template" so that I can just quickly replace text (With the "all text" dialog) and have everything line-up automatically.

IBMedia, 7 years ago

To do that:
-set the 1st dropdown below the text box to LEFT
-set the 2nd dropdown to VERTICAL ALIGN TOP
-set the 1st slider of the BOUNDS property to the desired width
-set the 2nd slider of the BOUNDS property to the desired height
-set the FONT SIZE property small enough to prevent scaling for most texts (scaling is only meant for exceptions)
-make sure your text does not have unnecessary hard returns.

Press F2 to visualize the rectangle.

michiel, 7 years ago


Thanks Michiel, I'll try what you suggest.

IBMedia, 7 years ago

I can't reproduce your WRITER remark. Nothing is re-scaled when the WRITER property is being animated.

michiel, 7 years ago


Michiel, I'll double-check what I'm saying about writer in a moment, and let you know.

Your instructions helped me get sorted out for the "word-wrap" and the key part of what you mentioned is the "BOUNDS HEIGHT"

To get it to work, it is essential that you have a height that is greater than you need.

That was the part that I had not done correctly - I had everything else, but had tried not settng the height, or setting it to a value that was too small.

I've now set my BOUNDS HEIGHT to 1000 and it's working exactly as I need - thanks.

IBMedia, 7 years ago

No problem. I'm happy it now works the way you want!

michiel, 7 years ago


I have it working just the way I want now. Many thanks for your help.

IBMedia, 7 years ago

Comment to this article

You must be logged in before you can comment to this article. Login | Register

More by IBMedia