NextPreviousHomeAnnouncing BluffTitler 12



michiel | 4 years ago | 23 comments | 13 likes | 16,282 views

LostBoyz, BillyJack, quangtrungkg and 10 others like this!

I am happy to announce that the next version, BluffTitler 12.0 will be powered by DirectX 11.

This is going to be THE biggest technology upgrade since version 1.0. DirectX 9 has served us well and is still working perfectly, but in order to harness the power of the latest generation of graphics cards we have to move on.

DirectX 11 gives us access to this power!

Moving from DirectX 9 to DirectX 11 is a huge step that we have already been working on for most of this year. Only recently our efforts have started to bear fruits.

On the above screenshots you can see the results of our latest experiments, all rendered with a beta version of BluffTitler 12.

COMPATIBILITY
Compatibility is a challenge. I am proud to tell you that version 12 will play your old shows!

TIMELINE
We are planning for an early 2015 launch. We will keep you informed in this gallery.

SYSTEM REQUIREMENTS
BluffTitler 12.0 will require:
-Windows 7, 8 or 10. 32 or 64 bits
-a graphics card that supports DirectX 11 (feature level 11.0 or higher)

Vista is supported, but only in combination with a DirectX 11 graphics card, which is a rare combination.

XP is no longer supported.

THANK YOU
Thank you for your continuing support. Thank you for making the DirectX 11 version possible!




Share this on Facebook Share this on Twitter

Powerful reflections effects!!!!
How to know if a video card supports D11 (i think to integrated card in my Toshiba portable).
I card doesn't support D11 what is BT12 behavior with DirectX9 ?
Thanks for informations.

vincent, 4 years ago


A big milestone in the history of Blufftiler journey, thank you for all your efforts,God bless you.
Unfortunately my Graphic card supports DirectX 10 only.

Dani, 4 years ago


BluffTitler 12.0. hopes to compatible XP

liuyongcai, 4 years ago


Thank you!

Vincent, take a look at the technical specs of your graphics card. It should say something like "Microsoft DirectX 11" or "Feature level 11".

BluffTitler 12.0 will require at least a DirectX 11 graphics card. Without it it won't run.

michiel, 4 years ago


Thank you Michiel,
BluffTitler is the best of the magic of technology.

Jesus, 4 years ago


Great news, I cannot wait for the mirror layer and play with it.

No more, every item I use most have a reflection fx to simulate a shiny floor.

And if you want to know which DX version your having; the command dxdiag(.exe) still works in the run line.

komies, 4 years ago


Michiel, software BluffTitler 12 is great, does not support XP very sorry. Will lose a lot of customers to buy, this issue should be considered.

liuyongcai, 4 years ago


Michiel, thank you for informations. I have updated my video drivers to be ready for BT12 but i'm not sure these drivers will support Dx11.
Once Dx11 is installed is it possible to come back to DX9 in case of problem. DX doesn't appear in installed programs list. I read somewhere you must create a system restoration point before to install and restore system at this point if Dx11 is not supported.

vincent, 4 years ago


DirectX 11 is preinstalled on Windows 7 and higher DirectX 11 cannot be installed on XP.

please type in your start/ menu/ run line DXDIAG this will show your directx version. in the first tab, in the secound tab will be your videokaart info, now you can google and check.

komies, 4 years ago


Komies thank you very much, dxdiag confirms what you say : Dx11 is already installed on my Window7.
Thanks again for your help.

vincent, 4 years ago


"Michiel, software BluffTitler 12 is great, does not support XP very sorry..."
+1
Very sorry, sorry, sorry.

Joel de GF, 4 years ago

Thanks komies, i got this info, is my card supports D11?

postimg.org...

Dani, 4 years ago


good morning Dani,

open DXdiag
click on display tab
here you can fnd your device name:
now you can checkit on Amd Radeon or Nvidea Geforce site

www.amd.com...
dx11 from hd 5000 and higher

www.geforce.com...
dx11 from gt 430 and higher.

komies, 4 years ago


Does your videocard support DX11?

solidlystated.com...

solidlystated.com...

komies, 4 years ago


Yes, the compatibility issues between DirectX, Windows, BluffTitler and your graphics card are pretty confusing. Hopefully this summary helps.

When I say "out-of-the-box" I mean that you only have to install BluffTitler itself and do not have to update or install DirectX or any other extra software.




This is the situation for BluffTitler 12 (the next version, planned for early 2015):

WINDOWS XP
BluffTitler 12 does not run on XP

WINDOWS VISTA
BluffTitler 12 will not run on your Vista system unless you replace your graphics card with a DirectX 11 compatible one

WINDOWS 7
BluffTitler 12 runs perfectly on your out-of-the-box Windows 7 system

WINDOWS 8
BluffTitler 12 runs perfectly on your out-of-the-box Windows 8 system

WINDOWS 10
BluffTitler 12 runs perfectly on your out-of-the-box Windows 10 system




This is the situation for BluffTitler 11 (the current version):

WINDOWS XP
After installing DirectX 9, BluffTitler 11 runs perfectly on your Windows XP system

WINDOWS VISTA
After installing DirectX 9 (*), BluffTitler 11 runs perfectly on your Windows Vista system

WINDOWS 7
After installing DirectX 9 (*), BluffTitler 11 runs perfectly on your Windows 7 system

WINDOWS 8
After installing DirectX 9 (*), BluffTitler 11 runs perfectly on your Windows 8 system

WINDOWS 10
After installing DirectX 9 (*), BluffTitler 11 runs perfectly on your Windows 10 system


(*) DirectX 9 does not replace higher versions of DirectX on Vista,7,8 and 10. Instead, it runs side by side with this higher version.

michiel, 4 years ago


Un saludo . veo por el buen camino la progresión del programa .
Esto esta encaminado a ser uno de los programas usado por grandes compañías con objetos de publicidad .
Me alegra ver que el progreso no a parado .

A greeting. see on track the progression of the program.
This is on track to be one of the programs used by large companies with advertising objects.
Glad to see progress not stopped.

maitegras, 4 years ago

Michiel, Version 12 looks awesome. I read your post on compatability and understand that it runs perfectly on system 7. I am running system 7 but my graphics board spec is Direct X 10. My question is will updating my graphics board to a board with Direct X 11 spec make any difference in the quality of output or provide access to any features that might not be available using my existing board?
Thanks, Everett

EverettM, 4 years ago

Windows 7 systems with a DirectX 10 graphics card are rare because Windows 7 and DirectX 11 were released at the same time. I was hoping my above simplification would stand, but apparently not =( Thank you for pointing me out on this. By the time version 12 is released we will communicate clearly that you need a DirectX 11 graphics card (as I did in the first place at the top of this page)

So to answer your question: BluffTitler version 12 will not run on your system. Installing a DirectX 11 graphics card will solve the problem.

michiel, 4 years ago


OMG! Please. A dream.

puffd, 4 years ago

BT12 DirectX 11 Very very GOOD!!

imagerz.com...

LostBoyz, 4 years ago


Yes indeed, very impressive !!! sure you'll do wonders.

vincent, 4 years ago


When is blufftitler 12 availlable????

Filip, 4 years ago


We're working weekends and nights for a June release. Thank you for your patience:

www.outerspace-software.com...

michiel, 4 years ago


Comment to this article

You must be logged in before you can comment to this article. Login | Register

More by michiel

About michiel

Michiel den Outer is the founder and lead coder of Outerspace Software. He lives in Rotterdam, the Netherlands.

If he isn't busy improving BluffTitler, he is playing the piano or rides the Dutch dikes on his bikes.

Contact michiel by using the comment form on this page or at michiel@outerspace-software.com